Scheduled Maintenance - Draft&Goal Studio (UI)

Incident Report for draftngoal

Resolved

Maintenance has been completed successfully. All systems are now operational.
Posted May 14, 2026 - 17:02 UTC

Investigating

We are performing scheduled maintenance to improve system performance. The Draft&Goal Studio web interface will be temporarily unavailable. Estimated completion: 2026-05-14T17:33:37Z
Posted May 14, 2026 - 15:33 UTC
This incident affected: Studio (UI).